The previously reported Cloud Secure Edge service degradation has been mitigated and services have returned to normal operation. Our monitoring indicates that authentication services, administrative console access, and platform operations are functioning normally. Engineering teams will continue to closely monitor the environment to ensure ongoing stability. We appreciate your patience while we worked to restore service.
Posted Jul 29, 2026 - 07:58 PDT
Investigating
Our investigation is ongoing. Customers may continue to experience intermittent authentication failures, difficulties accessing the administrative console, and delays or errors when synchronising device and application configurations. Mitigation actions are currently implemented and appear to be helping as our engineers continue root cause analysis. We will provide our next update within 30 minutes.
Posted Jul 29, 2026 - 06:46 PDT
This incident affected: United States (Command Center, API, Trustprovider).